Installing PHP Eclipse

From ALSwiki
Jump to: navigation, search

Install PHP Eclipse

Download and install Eclipse PDT All-In-One. Project page: http://www.eclipse.org/pdt/

The download page is here: http://download.eclipse.org/tools/pdt/downloads/

  • Unzip and move the "eclipse" folder to Program Files.
  • Create a shortcut and add it to your start menu.
  • Start it up. It will ask for a workspace location. The default is probably fine.

I already had EasyEclipse Server Java installed. PHP Eclipse started up with no problems. I did give it a separate workspace location to avoid mixing Java projects with PHP projects.

Install the Zend Debugger

  1. Select Help->Software Updates->Find and Install
  2. Select Search for new features to install, click Next
  3. Click the New Remote Site button...
    1. Name it
    2. Enter the URL: http://downloads.zend.com/pdt
  4. Zend Debugger now appears checked in the Sites to include in search list, click Finish
  5. The update manager searches for the files to download
  6. Check All Zend Debugger options on the Search Results screen, click Next
  7. Agree to the licensing terms
  8. Select the Zend Debugger in the Features to Install screen, you can change the install location, but the default is recommended, click Finish
  9. Verify the Zend Debugger on the Feature Verification screen, click Install All
  10. After installation you'll be asked to restart Eclipse for the changes to take affect

Click the Open-perspective icon on the upper right side of your Eclipse workspace and select the PHP Debug Perspective.

Install JSEclipse

To install JSEclipse with the Update Manager

  1. Select Help->Software Updates->Find and Install
  2. Select Search for new features to install, click Next
  3. Click the New Remote Site button...
    1. Name it
    2. Enter the URL: http://download.macromedia.com/pub/labs/jseclipse/autoinstall
  4. JSEclipse now appears checked in the Sites to include in search list, click Finish
  5. The update manager searches for the files to download
  6. Check the JSEclipse version check box on the Search Results screen, click Next
  7. Agree to the licensing terms, click Next
  8. Select JSEclipse in the Features to Install screen, you can change the install location, but the default is recommended, click Finish
  9. Verify JSEclipse on the Feature Verification screen, click Install All
  10. After installation you'll be asked to restart Eclipse for the changes to take affect

To create a new JS file, select New->File->Other->Web->JavaScript.

I'm not sure why this actually worked. Tried to access the Macromedia site directly -- It's moved to Adobe. Was able to download the zip file by logging in, just in case I need to re-install.